Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.


The "Cannot load direct3d" problem

Comment below rating threshold, click here to show it.


Junior Member


So today for the first time i have encountered the problem with "Cannot load direct3d" and i saw here on the forums that some people had this problem as well.
I don't know if this will help anyone but if there is a chance it might ill post it.

As i said today for the first time i encountered this problem and at first i was frustrated,after a few tries of starting up LoL i decided to close all of the programs i had running in the background to reinstall some drivers.
The programs that i closed were iTunes(an older version) and Starcraft 2.
Then while i waited for the drivers to download i tried to start up LoL and it worked,without installing anything new.

I tested it once again and ran Sc2+iTunes and tried to start up LoL and the same direct 3d message popped up.
I'm not sure why these would interrupt the game in any way but for me its the case.
If your having the same problem try checking or close the programs i listed or there might be others that cause this.

Comment below rating threshold, click here to show it.

Black Suzaku

Senior Member


It's really strange that LoL can't detect your Direct3D device whereas Starcraft 2 can. You may need to reinstall/uninstall things a couple of times and hold some experiments with different software combinations if you're looking for a challenge.

But the shortest way to get rid of this thing, format your PC.